Skip to content
IPv6 Buzz

IPv6 Buzz

All episodes.

210 episodes · showing the newest 200

WinCLAT Deep Dive

47 min

Richard Hicks joins Ed and Tom to discuss the general availability of WinCLAT and its role in supporting IPv4 applications on IPv6-only networks. They break down how WinCLAT removes technical barriers for IPv6 adoption by bridging compatibility gaps. They also discuss configuration methods using PowerShell and Group Policy, along with advanced troubleshooting techniques and telemetry... Read more »

Announcing Windows 11 IPv6 CLAT with Jim Alumbaugh

28 min

Ed, Nick, and Tom are joined by Jim Alumbaugh, Technical Program Manager for Windows Networking Protocols, to discuss the newly released IPv6 Windows CLAT support for Wi-Fi and Ethernet interfaces. Jim explains how this feature enables enterprises to accelerate migration to IPv6-mostly networks. They also examine technical considerations, industry adoption trends, and upcoming PowerShell tools... Read more »

IPv6-mostly Is Really Dual-stack

35 min

IPv6-mostly is a foothold to get from your dual-stack network to a much more predominantly IPv6-run network, but the reality is that IPv6-mostly has a whole set of dependencies about the fact that IPv4 exists on the network. Ed, Nick and Tom discuss the realities of IPv6-mostly networks such as DHCP and SLAAC configurations, VPN... Read more »

SREs Are Breaking IPv6 — And They Don't Know It Yet

30 min

Ed and Nick explore why developers and SREs often become the bottleneck when transitioning to IPv6-only environments. They share practical strategies for bridging the communication gap between network and application teams, including early collaboration, data-driven monitoring, and fostering open dialogue. Episode Links: Watch this episode on YouTube

IPv6 Address Management Is Broken

33 min

Traditional IPAM and DDI tools struggle to handle IPv6 at scale because they were originally designed around IPv4. Today Ed and Tom examine the visibility challenges posed by SLAAC  addresses, broken DNS integrations, and massive prefix allocations. They also share potential solutions and strategies for enterprise IPv6 deployment. AdSpot Sponsor: Megaport If you’re supporting cloud... Read more »

Flying Blind: Monitoring Might Not See IPv6

32 min

Is your current network monitoring infrastructure capable of seeing IPv6 traffic or are you flying blind in a dual-stack environment? Today Ed, Nick, and Tom explore the critical challenges surrounding IPv6 visibility such as the limitations of vendor tools and the complexities of maintaining observability as networks evolve.

Do IPv6 Mandates Work?

26 min

Nick Burgalio and Tom Coffeen discuss a Reddit post that had what appeared to be new federal guidance on IPv6 adoption. While it seems the timelines and guidelines haven’t changed, the post raises questions about the effectiveness of mandates in driving IPv6 adoption. They posit that enabling IPv6 is not just a technical requirement but... Read more »

Moving to Disable IPv4

1 hr 0 min

Franck Martin returns to the show to discuss the practical challenges of retiring IPv4 with hosts Ed, Nick, and Tom. Together they break down key strategies, how to work effectively with vendors, and how to mitigate potential outages during the transition. They also explore the cultural shifts necessary for successful IPv6 adoption and the importance... Read more »

Tayga and IPv6 Translation

40 min

Andrew Palardy joins the hosts to discuss how Tayga, the open-source NAT64 daemon for Linux, is being updated to ensure it is up to date with all the current RFCs. Andrew explains how recent RFC compliance and UDP checksum fixes help resolve connectivity issues and how the new eBPF CLAT support arriving in NetworkManager promises... Read more »

The Death of NAT

26 min

Network Address Translation (NAT), a foundational element of IPv4, faces critical reassessment as IPv6 deployment shifts the landscape. Ed and Tom evaluate the evolving role of NAT, questioning whether traditional translation models remain necessary when stateful packet inspection offers more robust, transparent security solutions. Episode Links: “Fanboy” series – IPv6 and NATs – YouTube

How to Get Hands-On IPv6 Deployment Experience

36 min

You can learn a lot about IPv6 from books, videos, and podcasts (such as this one), but it’s hard to beat hands-on experience. John Osmon joins our hosts to discuss how to set up your own IPv6 environment. They cover what John has done, including low-cost home lab options, how it’s impacted his thinking, and... Read more »

The Never-Ending Prefix Debate: Revisiting Best Current Practices

27 min

Today’s conversation centers around a new Best Current Practices (BCP) RFC draft written by Jordi Palet Martinez. Our hosts explore the document for service providers and enterprises, including prefix sizing for point-to-point links, the pros and cons of numbering choices, and best practices for prefix pool allocation. Episode Links: IPv6 Prefix Assignment to End-Sites –... Read more »

Yes, IPv6 Is Complicated. IPv8 Won't Help

33 min

Why is IPv6 so much more complicated than IPv4? Could a newer version such as IPv8 be the solution? Guest Brian Carpenter joins our hosts to explain that many of IPv6’s complications are mathematical necessities. They point out that IPv6 has a 30 year head start on any IPv8 proposal that would struggle with many... Read more »

Developing IPv6-Friendly Code

22 min

Tom Coffeen and Nick Buraglio welcome Chris Cummings to talk about developing code for IPv6. Chris argues that moving to IPv6 restores end-to-end connectivity, which reduces complexity for developers without the need for “ridiculous hacks” caused by IPv4 NAT. The discussion offers practical advice on avoiding common developer traps, and covers financial benefits such as... Read more »

IPv6 Privacy and Temporary Addresses

21 min

Today our hosts discuss IPv6 Privacy and Temporary Addresses to clarify how address provisioning can potentially work for host operating systems. The discussion covers the difference between permanent and temporary privacy addresses, their uses, and how interface identifiers are assigned to hosts.  

SLAAC and the End of DHCP?

26 min

Today our hosts discuss the essential role of Stateless Address Autoconfiguration (SLAAC) in successfully deploying an IPv6-mostly network. SLAAC is required to assign a unique IPv6 address to the Customer-side Translator (CLAT), which allows devices to operate on IPv6. However, enterprise operators might prefer using DHCPv6 for network tracking and accountability, potentially trapping them in... Read more »

Is End-to-End Connectivity the Right Goal?

27 min

One of the early design principles of the Internet was end-to-end connectivity: that is, every device on the Internet would be publicly addressable, and every device could share its resources or provide services. That design principle wasn’t achieved with IPv4 for a variety of reasons (including address scarcity, and many network owners not wanting endpoints... Read more »

Start Network Automation with IPv6!

18 min

If you’re looking for a network automation project but you’re worried about breaking stuff, why not build your automation adventure around IPv6? If your production traffic runs on IPv4, you can experiment with automated configurations and changes using IPv6 without negatively impacting that v4 traffic. You can get a two-for one experience learning both IPv6... Read more »

Naval Gazing at NAT in IPv6

38 min

Ed, Nick, and Tom discuss the need for Network Address Translation v6 to v6 (NAT66). While Network Prefix Translation (NPTv6) exists, its limitations make it insufficient for real-world business needs. They also highlight that without a standardized NAT66, the market is forcing vendors to implement their own, hindering widespread IPv6 adoption. Episode Links: IPv6-to-IPv6 Network... Read more »

IPv6 Basics - Troubleshooting

35 min

Are you struggling to get IPv6 working, whether in a lab or even a pilot deployment? Ed, Nick, and Tom walk through the essentials of IPv6 troubleshooting, revealing the non-negotiable differences between IPv4 and IPv6 that can trip up even experienced network engineers. They break down why blocking all ICMP, like in v4, will instantly... Read more »

IPv6 Lab Update

39 min

Thinking of setting up an IPv6 lab this year? Our hosts dive into a major update on building and testing modern IPv6 networks, focusing on the game-changing “IPv6-mostly” architecture. They break down the essential components you need to get this working, including DHCP Option 108 and the nitty gritty of client support. In this episode,... Read more »

IPv6 Predictions for 2026

47 min

Will Microsoft’s CLAT bring widespread adoption rates for IPv6? Will there be significant advancements in corporate and cloud adoption as well? Will this finally be the year we see the fix for the RFC 6724? Ed Horley, Tom Coffeen, and Nick Buraglio make their predictions for the new year in the first IPv6 Buzz of... Read more »

IPv6 in Kubernetes Deployments

21 min

Kubernetes is a popular container orchestration platform. Today’s IPv6 Buzz episode explores the benefits of using IPv6 in Kubernetes, and how Kubernetes uses IP addresses in both the control plane and data plane.We also address why the adoption rate is estimated to be so low, from default configurations to issues with non-IPv6-aware applications inside containers.... Read more »

RFC 9898 - Neighbor Discovery Considerations in IPv6 Deployments

30 min

The newly published RFC 9898 is the discussion of today’s podcast. The IPv6 Buzz crew explore the complexities of neighbor discovery and review solutions for both operators and architects. They share how this RFC serves as a single, detailed resource to improve your understanding of neighbor discovery and to reduce the potential attack surface in... Read more »

IPv6 Adoption for an Entire Country

35 min

What does it take for an entire country to adopt IPv6? Our guest today is Tenanoia (Noia) Simona, CEO of Tuvalu Telecommunications Corporation, the country’s sole telecommunications provider. She’s here to walk us through the difficulties of connecting the many islands of Tuvalu and their journey to achieving one of the world’s highest IPv6 adoption... Read more »

IPv6 RFC Updates

20 min

Today the IPv6 Buzz crew provides updates on the latest in IPv6 standards, RFCs, and best practices. They break down the recent discussions around RFC 6052, explore the options for RFC 8215, and share Nick’s spin on the now defunct testipv6.com site. Episode Links: RFC 6052 RFC 8215 RFC 6598 IPv6.army

An Inside Look at RFC 9872 for Discovering v6 Prefixes

20 min

RFC 9872 makes recommendations for NAT64 prefix discovery for hosts supporting v4-to-v6 translation. Co-host Nick Buralgio is a co-author of this RFC, so we’re taking the opportunity to talk about it in detail. We discuss the problems RFC 9872 is addressing and why a new RFC was needed for operational guidance, not necessarily defining a... Read more »

When IPv6 VPN and DNS Don’t Cooperate

17 min

Sometimes weirdness occurs within DNS if you’re on an IPv4 network and you connect to a dual-stack or v6-only VPN. Maybe the browser doesn’t connect, but you can still send pings, or vice versa. Is the OS getting confused about which stack and which order of interfaces to request services? Is the weird behavior being... Read more »

IPv6 Basics: Dual-Stack

25 min

We’re diving into another IPv6 Basics today with the topic of dual-stack, which means running the IPv4 and IPv6 protocol stacks simultaneously. We get many questions about the implications of running dual-stack, and in this episode we’ll provide answers. We start by getting a little finicky about the definition of dual-stack, and then talk about... Read more »

Measuring IPv6 and IPv6 Statistics

27 min

Today we talk about measuring IPv6 and IPv6 statistics. We talk about why it’s useful to measure IPv6, how to track v6 deployment initiatives, and tools to help with your measurements. Episode Links: Google IPv6 – Google IPv6 Global Statistics Dashboard IPv6 Enabled – Hexabuild Episode Transcript: This episode was transcribed by AI and lightly... Read more »

IPv6 Transition Technology Options

27 min

Transitioning from IPv4 to IPv6, or at least IPv6-mostly, is no easy task. Today’s show provides some education and advice about IPv6 transition mechanisms. We cover options such as NAT64, DNS64, PREF64, and more, as well as use cases. Also, if your technology vendors aren’t offering some of these mechanisms, ask for them – you’re... Read more »

Answering Your IPv6 Questions

25 min

You’ve sent in questions and on today’s IPv6 Buzz episode Ed, Nick, and Tom answer them. Questions include using DHCPv6 versus SLAAC in a home network, IPv6 and email services, a NAT66 recap, and more. Stay tuned for full episodes coming up that cover Path MTU discovery and IPv6 and containers.  Episode Links: Google IPv6... Read more »

IPv6 Basics - Deployment

31 min

We’re continuing our IPv6 Basics series discussing on this episode deployment.  We’ll help you sort out why you should deploy IPv6, things to consider before starting a deployment, and what approach you should take such as “inside out” vs. “outside in” and when you should deploy IPv6. Lastly we explain why you should seek out... Read more »

IPv6 DNS Gotchas

23 min

Let’s talk about common misconceptions regarding DNS and IPv6. We’ve heard these often enough that we felt we should talk through each one. We cover issues including what kind of DNS record types can be returned via IPv6 (and IPv4, too), more details on what really goes on with Happy Eyeballs, and combining A/AAAA records... Read more »

Remembering Fred Baker

28 min

Today’s show is in memory of Fred Baker, who passed away on June 18, 2025. Fred was a pivotal figure in the IPv6 community. He was the long-time chair of the v6ops working group, and had a distinguished career at Cisco as a Technical Fellow. To honor Fred and his contributions, we’re sharing our interview... Read more »

Introducing the IPv6 Compatibility Checker

15 min

The Hexabuild team is providing a new community resource, an IPv6 compatibility checker, for those trying to figure out IPv6 network hardware and software compatibility. It’s currently in an alpha version. We talk about what inspired it, what it does, and possible future updates. We also want to get your feedback on whether this is... Read more »

How to Number Point-to-Point Links

27 min

Let’s chat about point-to-point links. On today’s episode we cover what should and shouldn’t be done, and discuss why following RFC’s doesn’t always get you to the right place. We dig into questions including: Don’t we just use link-local addresses for point-to-points? Shouldn’t we assign a /127, just like we do a /31 in IPv4?... Read more »

IPv6 Basics - Link-Local Addresses

23 min

Our IPv6 Basics series continues with link-local addresses. Link-local addresses are unicast addresses used for addressing on a single link. The intent of link-local addresses is to let devices that may not have a router or global unicast address allocation mechanism still be able to communicate on a network segment. On today’s show we dig... Read more »

How Enterprise IPv6 Requirements Are Shaping Microsoft Windows

38 min

Today we talk with Tommy Jensen, a Senior Technical PM Strategist at Microsoft, about IPv6 support in Windows. Tommy shares what he hears from enterprises that are moving toward IPv6-mostly, strategies for dealing with older applications and devices that expect IPv4, and how the customer conversations he’s having about IPv6 now are more engaged and... Read more »

The IPv6 Test Pod Project

32 min

What if there was an simple way to test software and services to see if they work in a variety of IPv6 environments, including v6-only, dual-stack, and others? That’s the goal of the IPv6 Test Pod Project. This project provides a device, at no cost to the applicant, that comes with a variety of v6... Read more »

IPv6 SMB - Does it Work? Plus Other Listener Questions!

30 min

On today’s episode we’re doing some follow up on listener comments and questions that have come in via the Follow Up on packetpushers.net.  We cover questions regarding IPv6 for small businesses, then go even smaller and answer a question about IPv6 for home networks.  Lastly, we have a quick discussion about Path MTU discovery with... Read more »

IPv6 Basics - Routing

32 min

Our ongoing IPv6 Basics series continues with an episode on v6 routing essentials. We start with a comparison of various routing protocols: RIP, OSPF, IS-IS, EGP, and BGP. We look at pros and cons of each, and discuss challenges such as dual stack IPv4 and IPv6 network implementation, memory and resource use with IPv6, and... Read more »

RFC 7050 vs RFC 8781 for IPv6 Prefix Discovery

25 min

In this episode of the IPv6 Buzz, we dive into two RFCs for discovering IPv6 prefixes: 7050 and 8781. Why these two? First, 8781 is being proposed as preferential to 7050. Second, co-host Nick Buraglio is an author on 8781 and has insights to share. We start with some background on RFC 7050, including the... Read more »

10 Years of the UK IPv6 Council

27 min

IPv6 Buzz welcomes back Veronika McKillop, the founder and President of the UK IPv6 Council, to talk about the council’s formation and achievements in the past ten years. We look at IPv6 adoption in the UK and its challenges, and what the future holds for IPv6. Veronika highlights the need for improved IPv6 education in... Read more »

Deploying IPv6-Only Wi-Fi at the SC24 Conference

34 min

Want to know how an IPv6-only wireless network was deployed at a conference with 18,000 attendees? Join us as we talk through the technical details with Tom Costello, a senior network engineer at Argonne National Laboratory. Tom volunteers at the International Conference for High Performance Computing, Networking, Storage and Analysis (SC for short) to help... Read more »

Crossing the 50% IPv6 Adoption Threshold

21 min

IPv6 adoption should cross 50% in 2025. In today’s podcast, we discuss the implications and significance of IPv6 adoption reaching this milestone. While this transition might not be visible to average users, it does impact IT professionals. We explore varying adoption rates across industries, and talk about compliance requirements will soon necessitate IPv6. We also... Read more »

Reflections and Projections for IPv6 in 2024 and 2025

15 min

In this end of-the-year episode of IPv6 Buzz, we review the significant developments in IPv6 throughout 2024 and share projections for 2025. We discuss the introduction of a new documentation prefix, analyze IPv6 usage statistics, and review No NAT November.  For 2025, we explore the possibilities of updates to RFC 6724 and global adoption of... Read more »

IPv6 Basics - Address Planning

35 min

Continuing the IPv6 Basics series, today’s podcast addresses IPv6 address planning.  Special “guest” Tom Coffeen who literally wrote the book, IPv6 Address Planning, helps answer questions and gives advice on how to effectively plan IPv6 addresses. We discuss topics such as the importance of long-term planning and understanding prefix sizes, common design pitfalls, and the... Read more »

Getting a Fresh Start with IPv6

25 min

When you start fresh with IPv6, you have a lot to gain in terms of routing, reputation and security. Today’s show focuses on the differences between provider-assigned (PA) and provider-independent (PI) address spaces. The team discusses the benefits of PI space and the clean slate it offers for address reputation and security. As always, strategic... Read more »

Know Your Options: DHCP vs. DHCPv6

22 min

If you’re going to use DHCPv6, you have options, but there are some things you need to know in order to be able to build out your DHCPv6 configuration properly. Today’s IPv6 Buzz explores similarities and differences between DHCP and DHCPv6, particularly the operational model. And as always, you’ll want to verify and test before... Read more »

Up next

  1. Nothing queued. Use + Queue on any episode to line it up.

0:00 0:00